[Date Prev]   [Date Next] [Thread Prev]   [Thread Next] [Date Index]   [Thread Index]


     Re: [snips-users] RRDtool problem, and snmpmon problem


THe RRD error is probably because your RRD version is old? Can you try
downloading and compiling the latest version of rrdtool?


Moses Moore wrote:
> I'm using snips-1.2beta, and I remembered to install RRD tool before
> building.
> (Helpful: I noticed that the "Can't find RRDs.pm" problem required
> Debian's librrds-perl package to be installed.)
> When I want to look at the graphs for a device/host I'm getting broken
> images and this error message in my webserver's log files:
> RRD error for /usr/local/snips/rrddata/a/athena/DataAge.rrd - invalid
> rpn expression 'info,UN,UNKN,info,0,EQ,0,UNKN,IF,IF'
> I had to read the source and make a guess to find out what DataAge
> means; perhaps some *:default files could be added to 'device-help/' on
> installation?
> I'm also getting no data from the snmpmon -- execpt for DataAge.  After
> setting "$debug = 1;" in snmpmon, here's run/snmpmon.errors:
> snmpmon- Reading global config file /usr/local/snips/etc/snips.conf
> (snmpmon).. locked pid-file, started new process (pid=23222)
> (dbg) Total variables in config= 2
> (dbg) Configured thresholds are:
>          thress[0] = SYS.sysUpTime      .+      600     300     180
>          thress[1] = UCDAVIS.systemStats.ssCpuIdle      .+      25
> 15      01
> Doing datafile /tmp/snmpmon_data/mnemosyne.snmpmon
> ERROR: Could not open /tmp/snmpmon_data/mnemosyne.snmpmon:No such file
> or directory
> Doing datafile /tmp/snmpmon_data/mnemosyne.snmpmon
> ERROR: Could not open /tmp/snmpmon_data/mnemosyne.snmpmon:No such file
> or directory
> Here's my etc/snmpmon-confg:
> SYS.sysUpTime   *       600 300 180
> UCDAVIS.systemStats.ssCpuIdle   *       25  15  01
> mnemosyne       public  system ucdavis
> (UCDAVIS is something I added to bin/snmpmon-collector, copying the
> EMPIRE stuff.  I wouldn't bother the mailing list if just this was
> broken, but the above RRD tool stuff, and the absence of both ssCpuIdle
> and sysUpTime data makes me wonder.)
> /tmp/snmpmon_data didn't exist the first time I tried this, so I made it
> by hand.  Since /tmp tends to get erased on reboot for many UNIX
> machines, I changed line 95 to '/tmp/snmpmon_data' and uncommented line
> 105.  I tried changing them back but I still have these error messages.

Zyrion Traverse Network Monitoring & Network Management Software